PDA

View Full Version : ShipWorks Triggering Shipping Emails via API



GentleBath
07-23-2013, 11:58 PM
I use ShipWorks for my shipping and accidently found out that it is triggering my V store to send a Shipping Email even though I have them disabled in my Config Var Settings. I found out because I used my store email for a Samples order and when I received a shipment email from my store and SW I couldn't figure out why.

I emailed V support and they checked everything, and even tested an order but could not find anything wrong. They suggested I check with SW to see if their shipment update was sending a trigger via the API for the email and bypassing my settings -- Well that is what is happening, so no matter what setting I have in my Config Var when I upload my tracking info it triggers my store to send a shipping email.

I am wondering what those of you that use SW think about this. I am wondering if I am the only one that does not use the store email and would like the setting changed?

oxx155
07-24-2013, 10:37 AM
I thought SW had a setting to not send an email upon shipment?

GentleBath
07-27-2013, 07:52 PM
Yes, and mine is now set not to send. If I had a choice (which I guess now I don't) I would much rather send my shipping email from Shipworks for the following reasons:



I can preview what I am sending if I want
I can attach the invoice to my shipping email for the customer can see what is being shipped (I do a lot of partial shipments)
I can manually make changes to the invoice if need be
I can add notes to the email or invoice
I can go back and see what and when emails were sent and actually see them
I will get error messages if any emails are not sent for some reason


I already had a customer call confused when the email was sent later because I had to upload the shipping info a while since it was shipped and had already been received.

It is especially hard because I send a lot of partial shipments and V support has told me that it will work better if I do not mark the order as shipped before everything has been sent (and it does work better. But then when I mark it as shipped later the customers get confused. I feel like I am damned if I do and damned if I don't.

GentleBath
07-28-2013, 10:52 PM
Actually I had help from Volusion support on this - I had disabled the automatic upload of the tracking info because someone else at Volusion had suggested that I not mark orders as shipped until everything had been sent. Because I have so many partial orders I was manually choosing the orders in SW when I wanted to upload the tracking/mark as shipped.

By resetting the automatic upload I had an option to disable the Volusion email (ooxx15 - that is probably what you were talking about). Then I made a filter for complete orders and and made an action where the upload of the tracking would only happen when an order went into the Shipping Complete filter. I then disabled all my automatic updates to local status so I can mark the ones I want to be shipped and go into the Shipping Complete filter. (whew my brain hurts now).

I am hoping by using the automatic uploads that the Volusion emails will not be sent anymore. What do you think?